Knowledgebase
Stonefield Query Home > Stonefield Query Help Desk > Knowledgebase

Search help:


"Some of the required components could not be loaded" error message

Solution

Applies to:

  • Stonefield Query SDK

  • Stonefield Query for AccountMate

  • Stonefield Query for ACT!

  • Stonefield Query for Alere

  • Stonefield Query for GoldMine

  • Stonefield Query for HEAT

  • Stonefield Query for Sage 300

  • Stonefield Query for Sage Pro

If you get this error message when starting Stonefield Query, check the following:

  • Make sure you're running the latest version of Stonefield Query, as it has improvements in how these components are loaded.

  • Configure your anti-virus software to not scan the Stonefield Query folder.

  • Are you using Windows Vista or later? Stonefield Query cannot run on Windows XP or earlier versions.

  • Is there a file named sfquery.exe.config in the program folder? If not, unzip the attached Config.zip file in that folder.

  • Right-click wwDotNetBridge.dll and choose Properties. If there's an Unblock button, click it.

  • It might be that the version of the .NET framework is out-of-date. Go to https://www.microsoft.com/net/download/all and under the ".NET Framework" heading and the "Runtime" heading, click ".NET Framework 4.5.2" to download that version of .NET (you can also install a newer version, such as ".NET Framework 4.7.2" if you wish).

  • If you're running Stonefield Query on an older environment that doesn't support the .NET framework (for example, a Novell server), install the program on the individual workstations rather than the server.

 

Attachments:
config.zip config.zip

 
Was this article helpful? yes / no
Related articles SPFILES not found when running Stonefield Query for GoldMine
How to run WSSetup from the SDK folder
Error reading file on network drive or C000006 error
Article details
Article ID: 45
Category: Error Messages
Rating (Votes): Article rated 3.4/5.0 (5)

 
« Go back